Alerte Arcserve: "Failed to send Alerts to ..."

Section sur vos questions et problèmes sous Netware et OES (Open Enterprise Server) côté serveur uniquement.

Alerte Arcserve: "Failed to send Alerts to ..."

Messagepar boz37 » 18 Nov 2010, 14:58

Salut,

Configuration:
Mes 2 premiers serveur ont Arcserve 11.1Sp3 d'installé
Un Pc sous win XP toujours allumé avec le client Arcserve installé et le service Alerte de configuré.

A chaque fin de sauvegarde Arcserve écrit dans les logs "Failed to send Alerts to [Nom_du_PC_Ayant_le_service_Alert_de_lancer]

J'ai cherché sur le net et j'ai vu qu'il fallait vérifier les choses suivantes:
- Est ce que les paramêtres SMTP configurés sur PC ayant le service Alert Arcserve de lancé sont OK ? = OUI
- Est que le Message test envoyé depuis le PC ayant le service Alert Arcserve de lancé passe? = Test OK
- Est ce que les alertes sont configurées dans les Job ? = OUI
- Est ce que les fichiers Host des serveurs et du PC ayant le service Alert Arcserve de lancé renvoient bien les nom et les adresses IP de chacun ? = OUI
- Est ce que les ping depuis les serveurs vers le PC ayant le service Alert Arcserve de lancé fonctionnent ? = OUI
- Est ce que les ping depuis le PC ayant le service Alert Arcserve de lancé lvers es serveurs fonctionnent ? = OUI
- Est ce que les Nslookup depuis les serveurs vers le PC ayant le service Alert Arcserve de lancé fonctionnent ? = OUI
- Est ce que les Nslookup depuis le PC ayant le service Alert Arcserve de lancé lvers es serveurs fonctionnent ? = OUI
- Est ce que les port pour le service Alerte sont bien ouvert sur le PC ayant le service Alert Arcserve de lancé sont bien ouvert ? = OUI je pense mais pas sûr :?

Pour les ports j'ai créé une exception pour:
C:\Program Files\CA\SharedComponents\Alert\alert.exe
C:\Program Files\CA\BrightStor ARCserve Backup\ASAlert.exe
J'ai ouvert le port TCP 1070

Sur une autre site dont je m'occupe, j'ai un serveur MS2003 avec la mème version de Arcserve d'installer pour les sauvegardes de ce même serveur.
Le service Alert est aussi configuré sur ce même serveur puisqu'il y est en MS.
Avec cette configuration tout fonctionne parfaitement avec la même config SMTP et la même config de message d'alerte dans le Job que pour mes Serveurs Netware.

Comment puis savoir si mon problème vient d'un problème de port sans avoir à ouvrir complètment le firewall de mon PC ayant le service alerte de Arcserve de configuré ?
Est il possible de faire des tests d'envoi d'alerte depuis un Job créer uniquement pour ça dans Arcserve ? De cette manière je n'aurais pas à attendre lendemaine pour savoir si une modification apporté ici ou là résoud ou non le problème. Ca me permettrait aussi d'ouvrir le firewall que le temps du job test donc pendant un temps très court.

Salutations,
S1: NW6.5 SP7: Data, DNS-DHCP, Iprint, ARCserve 11.1 SP3.
S2: NW6.5 SP7, GW7.0 SP2, DNS-DHCP, GW, ARCserve 11.1 SP3.
S3: NW6.5 SP7, NetStorage, WebAccess SP3
Client NW 4.91 SP4 sous XpProSp3.
Client GW 7.0 SP3 sous XpProSp3.
Avatar de l’utilisateur
boz37
Expert maniaque
Expert maniaque
 
Message(s) : 222
Inscription : 25 Sep 2005, 22:11
Localisation : 95

Re: Alerte Arcserve: "Failed to send Alerts to ..."

Messagepar admin-forum » 06 Déc 2010, 16:08

Je suis un peu en retard mais la gestion des alertes sous .... MERDE tu nous parle de Windows.
Le service aLert fonctionne .

Par défaut, ARCserve enregistre l'état des travaux programmés dans son journal, et il est possible de les consulter depuis le Manager ARCserve. Toutefois, cela est inutilement fastidieux: il est plus simple de recevoir chaque jour une notification par courriel. Voici comment.

Le processus de notification d'ARCserve
ARCserve est pourvu depuis de nombreuses versions d'un mécanisme de notification très flexible au moyen du service "Alert", mécanisme qui figure dans les "options globales" lors de la soumission de travaux: diffusion (alerte écran), pager, SNMP, journal Windows (event), impression, courriel via Microsoft Exchange ou Lotus Notes, et CA Unicenter.

Ces nombreuses options n'incluaient pas de moyen pratique d'utiliser SMTP, bien que le choix SMTP figure également: en l'absence d'option de configuration, la notification par SMTP échouait faute de serveur. Depuis ARCserve 9 SP2, ce mécanisme est opérationnel.

Le mécanisme de notification passe donc par deux réglages: la configuration d'un profil de notification SMTP, et son utilisation dans les options de job. Examinons-les plus en détail.

Créer une configuration de notification SMTP
Le paramétrage des profils de notification est réalisé dans le gestionnaire d'alertes, accessible depuis le menu Manager/Alert du gestionnaire ARCserve.

Déplier le choix My Computer, puis Configuration, puis Brightstor AB, et enfin SMTP.

Un clic droit sur SMTP, puis SMTP settings donne l'accès aux paramètres SMTP (voir en fin d'article si ce choix n'est pas disponible):

•adresse électronique de l'émetteur : il s'agit du service Alert, mais il est préférable d'utiliser une adresse existante, pour que les éventuels retours d'erreur aient une chance de lui remonter. Utiliser l'adresse de l'administrateur réseau comme adresse d'émetteur est typiquement le meilleur choix.
•sujet : ce sera le titre du message transmis, qui est fixe. Cela permet par exemple de le filtrer automatiquement à réception dans la messagerie pour éviter un effacement intempestif
•SMTP Server: le serveur SMTP auquel Alert devra se connecter pour envoyer le message. En son absence, Alert n'émet pas de recherche DNS pour le MX du destinataire qui sera désigné ultérieurement, et la notification par SMTP échoue
Un nouveau clic droit sur SMTP, puis cette fois New Item permet de définir une destination SMTP: celle à laquelle la notification sera envoyée.

Une fois ces paramètres renseignés, le choix Send test message devient disponible, et il est prudent de l'utiliser pour tester l'envoi.

Il est maintenant possible de refermer le gestionnaire d'alertes pour retourner dans le gestionnaire ARCserve.

Créer et utiliser un profil de notification de job
Dans le gestionnaire ARCserve, choisir le job pour lequel une notification est souhaitée, et passer en modification.

Dans la barre d'outils du gestionnaire, cliquer sur Options pour accéder aux options générales du job, et cliquer sur l'onglet Alert dans la boîte à onglets qui s'ouvre.

Créer un profil de notification
Dans cette boîte de dialogue, cliquer sur la configuration des méthodes et destinataires d'alerte, qui n'inclut au départ que le choix <Par Défaut> (Default).

Dans cette nouvelle boîte, cliquer sur Nouveau (New) pour créer un profil, et lui donner un nom par exemple NotifyBySMTP.

Dans l'arborescence qui s'ouvre sous le nom de ce profil, choisir SMTP, puis cliquer à droite pour ajouter un destinataire. Choisir l'adresse électronique du destinataire de notification, et le nom d'affichage qui lui sera associé, et valider.

Enfin, valider cette configuration des méthodes et destinataires pour revenir à la boîte de dialogue d'options globales, sur son onglet Alertes.

Utiliser le profil de notificationA ce stade, il est possible de choisir à quels événements sera associée une notification. Pour chacun d'entre eux:

1.Choisir un événement à notifier dans la liste en bas à gauche: détection de virus, fin de job, etc
2.Choisir la méthode de notification: utiliser celle qui vient d'être définie, NotifyBySMTP
3.Si le journal de job doit être joint à l'envoi, cocher la case correspondante
4.Enfin, cliquer sur ajouter pour que cette combinaison événement/profil soit associée au job
Valider la boîte des options globales pour la refermer, et cliquer dans la barre d'outils du gestionnaire ARCserve sur Démarrer (Start) pour reconditionner et soumettre le job ainsi modifié.

Que faire si SMTP Settings n'est pas disponible ?Jusqu'à ses versions 6.x, Alert ne permettait pas le paramétrage du serveur SMTP. Vérifiez la version de votre gestionnaire Alert depuis le choix Aide/A propos (Help/About) du gestionnaire Alert.

Vous devez obtenir une version 7.0 build 699 au minimum. Si ce n'est pas le cas, vérifiez la version de vos fichiers individuellement, avec le dialogue Aide/Version: tous les fichiers sauf ceux appartenant à eTrust (l'antivirus intégré à ARCserve) et dont le nom commence par ET* doivent avoir une version majeure au minimum égale à 7.

Si vous utilisez une version 11 ou ultérieure, la version par défaut respecte ce minimum. En revanche, si vous utilisez une version 9, le gestionnaire d'alertes est d'une version antérieure: vous devez passer en SP2 au minimum. Pour cela, il faut réaliser DEUX mises à jour: d'abord passer en 9.01, puis de 9.01 en SP2. Cela représente deux téléchargements d'environ 60 Mo chacun avec un redémarrage système à chaque mise à niveau. Si votre version d'ARCserve est plus ancienne, vous devriez envisager une mise à jour.


--------------------------------------------------------------------------------
---- J'ai crée ce forum pour moi pour vous pour tous----
Avatar de l’utilisateur
admin-forum
Administrateur
Administrateur
 
Message(s) : 325
Inscription : 27 Oct 2004, 17:47
Localisation : Ile de France

Re: Alerte Arcserve: "Failed to send Alerts to ..."

Messagepar boz37 » 06 Déc 2010, 16:34

Salut,

Merci pour ce manuel mais malheureusement c'est déjà ce que j'ai fais :?
C'est d'ailleurs pour ça que je disais que je ne comprenais pas ce qui clochait car j'ai la même config sur un serveur MS2003 et tout focntionne donc je pensais que ça pouvait venir soit du poste client sous windows soit des serveur Netware eux même :?

T'cho
S1: NW6.5 SP7: Data, DNS-DHCP, Iprint, ARCserve 11.1 SP3.
S2: NW6.5 SP7, GW7.0 SP2, DNS-DHCP, GW, ARCserve 11.1 SP3.
S3: NW6.5 SP7, NetStorage, WebAccess SP3
Client NW 4.91 SP4 sous XpProSp3.
Client GW 7.0 SP3 sous XpProSp3.
Avatar de l’utilisateur
boz37
Expert maniaque
Expert maniaque
 
Message(s) : 222
Inscription : 25 Sep 2005, 22:11
Localisation : 95

Re: Alerte Arcserve: "Failed to send Alerts to ..."

Messagepar boz37 » 16 Jan 2011, 00:43

Salut,

Bon j'ai résolu mon problème,... enfin presque :mrgreen:

J'ai désactivé le firewall windows du poste où le service Alert est activé (pour une chose complètement différente que ce problème) et le lendemain surprise, j'ai reçu mes rapports de backup :lol:
Au début je me demandais ce qu'était ces mails mais dès que je l'ai est ouvert je me suis marrer :mrgreen:

Ce que je ne pige pas c'est que j'avais pourtant tout ouvert comme il faut à ce niveau donc il doit me manquer un port mais j'ai beau chercher sur le net je ne trouve pas :?
boz37 a écrit:Pour les ports j'ai créé une exception pour:
C:\Program Files\CA\SharedComponents\Alert\alert.exe
C:\Program Files\CA\BrightStor ARCserve Backup\ASAlert.exe
J'ai ouvert le port TCP 1070


C'est du délire d'avoir été bloqué à cause d'un problème aussi bête :?

T'cho

--------------------------------------------------------------------------------------------------------------------------------------------------------------------
EDIT: J'ai parlé trop vite, j'ai trouvé une liste de port dans ce topic sur une autre forum :)
111, 1024-5000 portmapper communication with the Manager
6050 TCP/IP communication with Client Agents
6051 TCP/IP communication with UNIX Client Agents
0XA234(UDP) NT Discovery Service
6052 Tape Engine
6053 Job Engine
6054 Database Engine
6050(TCP AND UDP) BAB Client Agent for Windows 6050(TCP AND UDP) BAB Client Agent for NetWare 6051(UDP AND TCP) BAB Client Agent for UNIX 6051(UDP AND TCP) BAB Client Agent for Linux
6055 and 6056 FOR BAB Open File Agent
6060(TCP) HTTPD
6070(TCP) BAB NT Database Agents
6070 BAB SQL Server Agent
6071(Named Pipes) BAB Lotus Domino Agent 6071(Named Pipes) BAB Oracle Agent 6071(Named Pipes) BAB Ingres Agent 6071(Named Pipes) BAB Informix Agent
6072(TCP) Communicator
6502(TCP) Tape Engine
6503(TCP) Job Engine
6504(TCP) Database Engine
41524(UDP) Discovery Service

Ca fait un peu beaucoup donc je vais les ouvrir 1 par 1 pour voir à moins que vous sachiez lequel est nécessaire :wink:
S1: NW6.5 SP7: Data, DNS-DHCP, Iprint, ARCserve 11.1 SP3.
S2: NW6.5 SP7, GW7.0 SP2, DNS-DHCP, GW, ARCserve 11.1 SP3.
S3: NW6.5 SP7, NetStorage, WebAccess SP3
Client NW 4.91 SP4 sous XpProSp3.
Client GW 7.0 SP3 sous XpProSp3.
Avatar de l’utilisateur
boz37
Expert maniaque
Expert maniaque
 
Message(s) : 222
Inscription : 25 Sep 2005, 22:11
Localisation : 95


Retour vers Serveur Netware / OES

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)

cron