Installation de eDirectory 8.8.2 [Problème]

Toutes questions sur les services annuaires (NDS ou eDirectory) ainsi que sur la réplication, les masters ou la synchronisation.

Installation de eDirectory 8.8.2 [Problème]

Messagepar nathonline » 14 Mai 2008, 14:23

Rebonjour,

Je me permet de vous consulter à propos d'un soucis qui est forcement assez désobligeant. Si jamais nous réussissons à résoudre ce problème, je pense que cela pourra être un petit mémo pour l'installation de eDirectory.

OS : Suse Linux Enterprise 10
eDirectory : eDirectory 8.8.2

Voici la méthode que j'utilise pour installer eDirectory :

Tout d'abord je telecharge l'image iso d'eDirectory sur www.downloads.novell.com ( nécessite un compte qui est gratuit )

Je créé une route de multidifusion :

Code : Tout sélectionner
route add -net 224.0.0.0 netmask 240.0.0.0 dev [i]eth0[/i]

Attention cette commande est un ajout de route en dynamique c'est à dire qu'au redémarrage de la machine, cette règle sera perdu. Il est possible de l'ajouter en static en allant dans Yast --> Services Réseau --> Routage --> Configuration Expert --> Ajouter

Après l'installation de SLE 10, j'insère mon image d'eDirectory puis tape la commande suivante dans le terminal :

Code : Tout sélectionner
suse:~ # /media/cdrom/setup/nds-install


On me demande d'appuyer sur "enter" ce que je fais et j'accepte la licence

J'ai le choix entre l'installation de Novell eDirectory Server et Novell eDirectory Administration Utilities. Je choisi les deux en tapant "1,2"

Voilà, normalement mon eDirectory est opérationnel.

Il s'agit maintenant de commencer les paramétrages de mon eDirectory.
Pour cela je fais :

Code : Tout sélectionner
suse:~ # /opt/novell/eDirectory/bin/ndsconfig add

On me demande alors le nom de mon admin avec son contexte, ce qui sera dans l'exemple : admin.org
ensuite mon mot de passe : ****
le nom de l'arbre : root-suse-NDStree
le nom de contexte du server : org
le chemin absolut de l'instance : /var/opt/novell/eDirectory
le chemin absolut de la db : /var/opt/novell/eDirectory/data/dib

Et là c'est le drame :

Code : Tout sélectionner
Starting the service 'nsdsd' ... Done.
Checking if server is ready to service requests... Done

Searching for the Tree "ROOT-SUSE-NDSTREE" in the network. Please wait ... The given tree does not exist.
Verify the existence of the treename unsing slpinfo or specify IP address to configure.
Stopping the service 'nsd'... Done.



En bon francais je pense qu'il essait tout simplement de me dire : "Dégage ton SLP est mal configuré, si tu veux contourner le problème créer toi un fichier avec des entrées statiques".

Donc voila j'aimerai bien que vous me donniez un petit coup de pouce. Sur cette partie de la configuration. Y a pas de raison que l'installation se passe bien sous windows et mal sous linux :).

voici mon fichier /etc/hosts.nds :
Code : Tout sélectionner
Internet address
ORG.
suse.test.org
suse.ORG.
10.105.111.79

Internet address
SUSE
suse.test.org



et mon fichier /etc/slpuasa.conf :
Code : Tout sélectionner
#Refer Man pages to set the following parameters and remove # for the parameter
#net.slp.MTU =
#net.slp.isBroadcastOnly =
#net.slp.isMulticastOnly =
#net.slp.MulticastRadius =
#net.slp.useScopes =
DA_ADDR = 10.105.111.79

Merci d'avance
Dernière édition par nathonline le 15 Mai 2008, 15:28, édité 5 fois.
nathonline
Mini-maniaque
Mini-maniaque
 
Message(s) : 19
Inscription : 14 Mai 2008, 09:26
Localisation : Nantes

Re: Installation de eDirectory 8.8.2 [Probleme]

Messagepar Raymond » 14 Mai 2008, 17:27

nathonline a écrit:
Code : Tout sélectionner
suse:~ # /opt/novell/eDirectory/bin/ndsconfig [b]add[/b]


add veut dire : s'intégrer dans une arborescence existante

Toi pour l'instant tu veux créer une nouvelle arborescence donc
ndsconfig new

Si tu connais tous les paramètres, tu peux les ajouter directement sur la ligne de commande.
Raymond

Apprends comme si tu devais vivre pour toujours
et vis comme si tu devais mourir ce soir!
Proverbe tibétain
Avatar de l’utilisateur
Raymond
Administrateur
Administrateur
 
Message(s) : 302
Inscription : 12 Déc 2005, 14:02
Localisation : Thonon - 74

Messagepar nathonline » 15 Mai 2008, 15:49

Héhé, moi qui croyait que ça allait marché aussi simplement que ça ;) ...
Je vais être encore obligé de vous soliciter. D'ailleurs ça permettra de faire une sorte de knowledge de tout les problèmes de mise en place :) [ qu'est ce qu'il faut pas faire pour justifier un post :p ].

Bref ... Mon installation me paraissait valide, jusqu'à que j'essaye d'ouvrir une session ( actuellement le client se trouve sur windows ). En fait il ne trouve pas d'arborescence ... J'ai l'impression que c'est le daemon "slpd" ou le fichier "hosts.nds" qui est mal configuré ( d'ailleurs les deux ont les memes roles non ? ). Vous pouvez voir la conf de /etc/hosts.nds et /etc/slpuasa.conf au premier post de ce topic. Bien evidemment j'ai lancé le daemon slpd apres avoir configuré le fichier /etc/slpuasa.conf
nathonline
Mini-maniaque
Mini-maniaque
 
Message(s) : 19
Inscription : 14 Mai 2008, 09:26
Localisation : Nantes

Messagepar Raymond » 15 Mai 2008, 17:24

nathonline a écrit:Mon installation me paraissait valide, jusqu'à que j'essaye d'ouvrir une session ( actuellement le client se trouve sur windows ). En fait il ne trouve pas d'arborescence

Pour valider l'install, mets l'adresse IP du serveur NDS dans le champ arborescence.
Raymond

Apprends comme si tu devais vivre pour toujours
et vis comme si tu devais mourir ce soir!
Proverbe tibétain
Avatar de l’utilisateur
Raymond
Administrateur
Administrateur
 
Message(s) : 302
Inscription : 12 Déc 2005, 14:02
Localisation : Thonon - 74

Messagepar nathonline » 16 Mai 2008, 08:36

Encore une fois : Tu avais tout bon Raymond :)

Cependant je trouve cela étrange que l'on soit obligé d'attaquer par l'adresse IP. Et de plus, une fois loggué sur une session, je retourne sur l'invite de connexion Novell, si je clique sur Arborescence il ne voit toujours pas mon petit arbre ... même si je tape le nom de mon arborescence.

Ça m'a l'air d'être un problème de configuration non ?
I want to be a novell star ... :o
nathonline
Mini-maniaque
Mini-maniaque
 
Message(s) : 19
Inscription : 14 Mai 2008, 09:26
Localisation : Nantes

Messagepar nathonline » 19 Mai 2008, 09:19

Aucune idée ? :roll:
I want to be a novell star ... :o
nathonline
Mini-maniaque
Mini-maniaque
 
Message(s) : 19
Inscription : 14 Mai 2008, 09:26
Localisation : Nantes

Messagepar Raymond » 19 Mai 2008, 16:16

nathonline a écrit:Cependant je trouve cela étrange que l'on soit obligé d'attaquer par l'adresse IP.

J'avais dit pour valider l'install.

nathonline a écrit:Ça m'a l'air d'être un problème de configuration non ?

C'est effectivement un problème de configuration SLP.

Le fichier de config de slp Directory Agent est /etc/slp.conf
entre autres : net.slp.isDA=true

A moins que tu aies un autre DA sur le réseau ?
Raymond

Apprends comme si tu devais vivre pour toujours
et vis comme si tu devais mourir ce soir!
Proverbe tibétain
Avatar de l’utilisateur
Raymond
Administrateur
Administrateur
 
Message(s) : 302
Inscription : 12 Déc 2005, 14:02
Localisation : Thonon - 74


Retour vers eDirectory et NDS

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron